The DX4500/DX4600 Client software errors with a bksocket.dll failed to register and missing MFC71.dll message during installation.

NOTICE

DISCONTINUED PELCO PRODUCT.
This product has been discontinued. For further information please visit pelco.com/support/discontinued-products

Issue

During the installation of the client software there will be two error messages displayed but the installation will finish.
Error 1 = bksocket.dll failed to register
Error 2 = unable to locate component MFC71.dll



After finishing the installation and launching the software, it's possible to also encounter the following errors.

DX4X00_Video.ax


DX4X00_MPEG4.dll

Product Line

Pelco Video Management

Environment

  • DX4500/DX4600 Client v1.4.0.0026
  • Microsoft Windows XP
  • Microsoft Windows 7

Cause

  • The DX4500/DX4600 Client v1.4.0.0026 software is not able to be installed over the top of a previous version of DX4500/DX4600 Client.
  • Installing DX4500/4600 PC Client software v 1.4.6 Client does not overwrite the previous installed clients causing (Missing error MFC71.dll)

Resolution

To resolve this issue you will need to copy the MFC71.dll file In the Export Viewer directory into the Network Client.

  1. Navigate to C:\Program Files\Pelco\PELCO DX4500_4600 Client\Export Viewer 
    Note: 
    For Windows 7 64bit platforms use Program Files (x86)
     
  2. Locate the file MFC71.dll then right-click and select Copy.
  3. Go to C:\Program Files\Pelco\PELCO DX4500_4600 Client\Network Client and paste the MFC71.dll into the directory.
  4. Close and reopen the DX4500_4600 Client software.



To resolve the issue with error DX4X00_Video.ax or DX4X00_MPEG4.dll

  1. Navigate to C:\Program Files (x86)\Pelco\PELCO DX4500_DX4600 Client\Export Viewer
  2. Copy the DX4X00_Video.ax or DX4X00_MPEG4.dll file 
  3. Go to C:\Program Files (x86)\Pelco\PELCO DX4500_DX4600 Client\Network Client and paste into the directory.