Does the Endura NSM5200 support 3TB hard drives?

NOTICE

POTENTIAL FOR DATA LOSS.
The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure, please contact Product Support Services prior to attempting the procedure below.

Issue

One or more 3TB hard drive(s) is to be installed into an Endura NSM5200.

Product Line

Pelco Video Management

Environment

  • Endura NSM5200's 02.01.05.0001 and below.
  • 3ware / LSI RAID Controller 4.10.00.020 and below.

Cause

The 3ware/LSI RAID controller card on the NSM5200 must be at firmware version 4.10.00.021 or above. 

Identification:
To identify the firmware version of the 3ware / LSI RAID controller installed in the NSM5200, perform the following steps.

  1. Login to Endura Utilities as a user with administrative writes. The default username is admin and the default password is admin.
  2. Under the System Attributes tab, 
  3. Right click on the NSM5200 in question. This can be either the NSM5200 service or NSD service listed in Endura Utilities.
  4. Select Scripts One-time script.
  5. Type the command tw_cli /c3 show firmware and click OKPlease note that your controller number may vary. The most common is /c3 but if an error occurs try /c1 or /c2.
  6. After the script completes the firmware version will be displayed in the Utilities details box. Verify that the version displayed is 4.10.00.021 or above.

Resolution

There are two possible resolutions.
WARNING: If 3TB hard disk drives have previously been installed on an NSM with older LSI RAID Controller Firmware - which does not properly support them - it would have resulted in the RAID Array being created with a lower than maximum capacity. In this case, any video which has been recording at this lower-than-maximum capacity since the drives have been installed, will be lost after upgrading the LSI RAID Controller Firmware, which will automatically re-create the RAID 6 Array based on the new maximum drive size it now properly recognizes.

Option 1:
Update the NSM5200 to version 2.2.x or greater. This version contains a firmware update for the 3ware / LSI RAID controller card that supports 3TB hard drives.  Note:  There have been reports that the BIOS may remain at  < v4.10.00.021 regardless of the NSM5200 update to version 2.2 or higher.   If this is the case, then proceed to Option 2


Option 2:
Utilize the attached NSM5200_3wareLSI_fw4.10.00.024.tgz tool to manually update the 3ware / LSI RAID controller firmware. This update will flash the firmware to version 4.10.00.024. To update the firmware via this method, follow the steps below. The typical update time is 5-15 minutes plus one system reboot.

  1. Download the attached NSM5200_3wareLSI_fw4.10.00.024.tgz file and save it to a PC that contains Endura Utilities and has access to the Endura system.
  2. Open Endura Utilities and login as a use with administrative writes. The default username is admin and the default password is admin
  3. Right click on the NSM5200 in question. This can be either the NSM5200 service or NSD service listed in Endura Utilities.
  4. Select SCP > Copy file to
  5. Browse for the file saved in step one and click Open.
  6. When prompted for a remote path, type /root and click OK. Wait for the file transfer to complete.
  7. Right click on the NSM5200 that you just copied the file to and select SSH Into. The default username is root and the default password is pel2899100. If a security warning message is displayed, select Yes to continue.
  8. While in the SSH session type each command below followed by enter  to complete the upgrade process.
    1. cd /root
    2. tar -xzvf NSM5200_3wareLSI_fw4.10.00.024.tgz
    3. ./UpdateLSI
  9. The update process will now start. Wait for the NSM5200 services to stop (5-15 minutes) and when prompted if you would like to continue, press Y.  The tool will then proceed to flash the RAID controller. 
  10. After the flash completes, you will be presented with the message Update tasks complete. Please reboot your system.
  11. Type reboot and wait for the system to start up normally. The identification steps above can then be run again to confirm the update was successful.