Pelco Mobile requirements connecting to Digital Sentry recorders?

Issue

Would like to connect to a Digital Sentry DVR/NVR using the Pelco Mobile application

Product Line

Pelco Video Management

Environment

  • Pelco Mobile (app)
  • DS v7.3.54 - v7.7.309
    • DS Web Service v2.0.0 - v2.1.0.1885
  • DS v7.8.90 or later
    • DS Pelco API Bundle Installer v7.8.90 or later
  • Digital Sentry

Cause

There are minimum requirements which must be met in order to install and run the Pelco Mobile application with a Digital Sentry recorder.

Resolution

Please read through all requirements before downloading any software.

Requirements:

  • The user password cannot contain any special characters, use only alpha numeric characters.
  • The Digital Sentry system must be operating on software version v7.3.54 or later
     

 - With DS / DSSRV(2) server software versions 7.3.54 - v7.7.309

The DS Web Service must be installed on the Digital Sentry system.

                      Download (Direct) DS Web Service v2.1.0.1885 or (Pelco.com) DS Web Service link 

             Note: Digital Sentry software version v7.5.609 requires DS Web Service version v2.1.0.1873 or above.

Note - (Windows XP/2003 Server only): With Digital Sentry recorders running on Microsoft Windows XP,  the Windows XP Service Pack 2 Support Tools must be installed before installing the DS Web Service.  When installing the support tools, make sure to select "Complete" when prompted. MS .NET Framework 4.0 Client Profile/Extended (DS Web Service installation requirement, installer will download required update if needed, internet connection required.)
 

 - With DS / DSSRV(2) server software versions v7.8.90  or later (to current version)

Use the DS Pelco API Bundle Installer instead of the DSWebService on the Digital Sentry system.

Download the DS Pelco API Bundle Installer  which matches your Digital Sentry software version.
 

Note - The Frame Server, PelcoAPI and DS Serenity Services are needed.  Install Frame Server first, then Pelco API followed by DS Serenity. Please see the readme.txt file in the bundle for specific installation instructions. 
If the Admin account password has been changed from default  it may also be necessary to refer to the articles. DS FrameServer, Serenity, and API service fail to install, How to update the DS API password connected to a DS system.
 

  • On the phone or tablet, check the Android Play Store or Apple AppStore to verify running the latest Pelco Mobile App version and what the listed DS requirements are for that version (In app click on Help (?) > General Information > About Pelco Mobile).
     
  • Pelco Mobile connection to Digital Sentry uses network port TCP 443 (SSL).
    • Configure in the router for port forward.
       
  • The Digital Sentry Video Server service must be configured to use its default network port of TCP 18772.
    • Setting Located in DS Admin VAU'S Info Tab.
       
  • Android phones and tablets running 3.x or greater.
    Note: Some Android devices may require 4.x or greater for full functionality, particularly PTZ support.
     
  • Apple phones and tablets running iOS 5.x or greater.
     
  • The Pelco Mobile application does not use the Microsoft Windows authentication feature of Digital Sentry.
    • Users that use the Mobile application must use a user account that is defined through the 'User Administration' feature within DS Admin.
    • Please see the knowledge base article titled 'Adding a user account to Digital Sentry using DS Admin' for additional information.
       
  • Pelco Mobile supports video playback as of v2.0.x.x and above.
     



Click here for example diagram: 
 

Related articles:

How to install the DS WebService onto a Digital Sentry system.
Changing Pelco Mobile's main connection Network Port 443.
Pelco Mobile does not connect to a Digital Sentry NVR behind a Router/Gateway
Pelco Mobile DS Web Service installer errors with "HttpCfg.exe was not found" on a Windows XP or Server 2003 system