Issue
Installed I/A Series G3 Workbench on a new computer with Windows 7 Professional 32-bit and the host ID changes each time Workbench is started. This has been seen on new Dell laptops and computers that have been provided a replacement hard drive with Dell operating system (Microsoft OS) installation disks.
Environment
I/A Series G3 build 3.4.xx, Enterprise Server, Workbench
Cause
Host IDs continuously change as the software does not have rights to write the encrypted host ID key into the registry.
Resolution
Locate the Niagara service and Workbench executables (niagarad.exe and wb.exe). These files are located under the niagara's directory (bin folder).
Example: \niagara\niagara-3.x.xx\bin
Right click and select properties for each executable.
Select the compatibility tab and check the "Run this program as an administrator" privilege level checkbox. The host ID is now allowed to be written to the registry by the software.