Troubleshooting AS configuration issues with IP address

Issue

Default IP Address for AS,TCP/IP IPv6, and StruxureWare Building Operation

Product Line

SmartStruxure Solution

Environment

StruxureWare Building Operation site

Cause

Attempted to ping AS and got "Request timed out." (AS does not have a default IP address)

After going through StruxureWare Building Operation Device Administrator's Open Console which is also referred to as PuTTY(outlined below #1), the configuration has the proper:
Hostname
DHCP enabled/disabled
IP address
Subnet mask
Default gateway
DNS server
Domain name

Still the ping of the AS ip address receives "Request timed out" 

Is this from a Virtual environment? See Resolution 6 below.

Resolution

Check the following settings:

1.
Use Device Administrator to set a static IP address for an Automation Server.
Connect the Automation Server to the PC's USB port
In Device Administrator, select the Automation Server you want to set the IP address for.
On the View menu, click Console which opens console or PuTTY.  See NOTE below if Console icon not shown.
If you are prompted to type a login name, default is “admin”. Press Enter.
If you are prompted to type a password, default is “admin”. Press Enter.
Type “setip”. Press Enter.
If you want to change the host name, delete the current host name and type a new host name. Press Enter.
Type “no” to use a static IP address. Press Enter.
Type the IP address for the Automation Server. Press Enter.
Type the subnet mask. Press Enter.
Type the default gateway address. Press Enter.
Type the DNS server address. Press Enter.
Type the domain name. Press Enter.
Type “yes” to write the configuration. Press Enter.
After the Network settings successfully updated message is displayed,
Type “exit” to log off. Press Enter.

2. Rather than connect through a router or switch, plug the Ethernet cable directly into the AS. No crossover cable required.

3. Adjust IP settings to close proximity IP and Subnet such as the following example:
Computer IP=192.168.1.2
Computer Subnet=255.255.255.0
Automation Server IP=192.168.1.5
Automation Server Subnet=255.255.255.0

4. Have only one NIC or network card enabled in Network Settings on this computer

5. In Network Settings, uncheck the Internet Protocol Version 6 (TCP/IPv6) which will disable. TCP/IP Version 6 is the latest version of the internet protocol which provides communication across diverse interconnected networks which is not necessary for this configuration.

6. If you are using a virtual environment, exit that virtual environment and attempt the configuration from the real world environment. 

7. If AS hangs or comes up with the Status light in red:

  • Start Device Administrator and establish USB connection between computer and AS.
  • Press the reset button on the AS three times in a row to place it in DFU mode.
  • The AS will disappear from the Device Administrator and re-appear in DFU mode.
  • Perform Upgrade device operation.
     

8. The AS can be configured using DHCP (Dynamic Host Configuration Protocol) using Device Manager. It is recommended to not use DHCP but rather Static IP addresses. If the IP of the AS/ES changes, then reconfiguration of other AS/ES, or BACnet/IP, Modbus/IP interface needs to be changed also.

NOTE: Beginning with StruxureWare Building Operation release 1.4.0, the Device Administrator no longer displays the "Console" icon on its tool bar.  You can still access the PuTTY console by holding down the shift key and right clicking on the automation server. You will have the option to open 'Console'.

 

NOTE: Some network configurations setting changes may be prevented by the connected network. If you are having issues getting the AS to save changes, disconnect the AS from the ethernet and use the USB connection only.