DS Backup fails to archive the Digital Sentry database after changing the SA password.

Issue

 

  • An error message stating "Can not determine database location" is displayed in the DS Backup status window.

 

  • Connection failed: Login failed for user 'sa'.


     

Product Line

Pelco Video Management

Environment

Digital Sentry 

  • Version 7.2.30
  • Version 7.2.46 - 7.4.320

Cause

The SA password has been changed, the query fails and returns the message specified.

Resolution

There are now a couple of options:

  1. Upgrade to Digital Sentry version 7.4.363 or higher.
    • DS Backup will issue an error following changes to the SA password indicating that the user’s previous credentials have failed; clicking OK to exit the error will prompt the user for new credentials and allow the user to continue the backup process.

  2. Change the SA password back to factory default LETmein333.
    1. Open SQL Server Management Studio
    2. Select "Connect"
    3. Select the plus next to "Security"
    4. Select the plus next to "Logins"
    5. Double click "sa" and a [Login Properties - sa] menu will appear.
    6. Clear out password and type LETmein333 (again in confirm password).
    7. Select "OK' and close out SQL Server Management Studio.
    8. Proceed with DSBACKUP.

 

With newer versions (DS 7.4 or greater) you will get a prompt to enter the new 'sa' credentials

  1. Click OK to the Connection failed message.



     
  2. Verify the correct connection information for Server: (computername/DS_MSSQLSERVER)



     
  3. Enter the 'sa' password if it was changed. Then click OK




    Note: Make sure the SQL Server (DS_MSSQLSERVER) service is 'Started'. If the SQL service fails to start the DS Backup utility will be unable to create a DB archive.