Failed to initialize view, access denied or type mismatch

Issue

Failed to initialize view, access denied or type mismatch when logging in to workstation with some users.

Product Line

TAC Vista

Environment

TAC Vista

Cause

When you log in to TAC Vista workstation a default alarmview is always opened (if you are using user profiles you can specify other alarm views.

All users that are using the default alarm view have to have at least read rights to $AlarmColumns, $AlarmView and $DisabledView

Resolution

  1. Log in with a system user
  2. Right click on the $AlarmColumns and select authority.
  3. If everyone is not in the access control list with at least read rights drag everyone from the Group/users list.
  4. Repeat for $AlarmView and $DisabledAlarms