How to run the DS Refresh Script to resolve a database mismatch within the Digital Sentry software?

Issue

  • After updating the DS software or importing an older database backup, the DS database version does not update to the current installed Digital Sentry software version.
  • After updating the DS software unable to search recorded video.
  • After updating DS software dragging camera into screen display crashes ds controlpoint. 

Product Line

Pelco Video Management

Environment

  • Digital Sentry  version = 7.x.x and above.
  • DSSRV / DSSRV2
  • DS NVs
  • DS

Cause

When updating the Digital Sentry software or importing a previously backed up database, the SQL database does not update all SQL tables.

Resolution

This can be confirmed by running the DS Admin utility and once connected to the VAU, look at the information in the title bar of the DS Admin window.

Example:

  • DS v7.4.149 software should have a database version of 7.4.0.x
  • DS v7.3.208 software should have a database version of 7.3.0.x





 

  1. Go to Start > Run or Search Bar > type cmd then hit Shift + right click and select Run as a different user. Login username = dsnvsuser / password Pelco123.

  2. Run the following command in the command prompt.
    sqlcmd -S localhost\DS_MSSQLSERVER -i C:\digitalsentry\ds_refresh.sql
     
  3. The refresh script is complete when then DOS prompt returns, close the command prompt window and verify DS Admin and database version now matches.
     

Note:

Digital Sentry 7.5.609 will show a database version of 7.4.0, this was an issue with that software release and has been corrected in future versions.

Digital Sentry 7.12.153 will show a database version of 7.11.0.0.