How to pull 3Ware RAID Controller Logs from Endura NSM5200/SM5200/EE500.

NOTICE

POTENTIAL FOR DATA LOSS.
The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure, please contact Product Support Services prior to attempting the procedure below.

NOTICE

COMPLEX PROCEDURE REQUIRED.
The resolution of this article has many complex steps that may result in unforeseen results if not performed correctly. If you are at all unfamiliar with the requirements, please contact Product Support Services for assistance.

Issue

In depth HDD/SSD investigation is needed.

Product Line

Pelco Video Management

Environment

  • NSM5200
  • EE500
  • SM5200

Cause

Hardware investigation is needed.

Resolution

*NOTE: This article uses the term "the unit" in reference to the Endura NSM5200, SM5200, or EE500 System that you the reader intend to gather diagnostic logs from.

Section 1
Determine if the lsigetlunix.sh script is already present on the unit...

  1. Launch Pelco Utilities (formerly Endura Utilities).
    note: See LL#9917 for logon credentials.
     
  2. Follow LL#13089 to SSH into the unit.
     
  3. Type the command find / -name lsigetlunix.sh and press enter. Depending on the result, choose either option a or b below...

    a. If the search locates lsigetlunix.sh, take note of the file path for use during the remainder of the steps in this article, then bypass Section 2 and skip directly to Section 3.

    note: The file path is /root/.DONOTRUN/3ware_diagnostics/ in this example.

    or...

    b.
    If lsigetlunix.sh is not found, proceed to Section 2 below.

 

Section 2
Download, transfer and extract lsigetlunix...

  1. Download lsigetlunux.tgz.
     
  2. From Pelco Utilities (formerly Endura Utilities), transfer lsigetlunix.tgz to the unit...

    a. Right click on the the unit and select SCP > Copy files to...

    note: Use "Search" or "SM Search" if the unit is not shown within Pelco Utilities.

    b. Select the downloaded lsigetlunix.tgz file and click Open...


    c. At the Remote Path dialog, enter  /root  then click OK...

     
  3. Follow LL#13089 to SSH into the unit.
     
  4. Create a folder by typing mkdir /root/.DONOTRUN/3ware_diagnostics and press enter.
     
  5. Extract lsigetlunix.tgz by typing  tar -zxvf lsigetlunix.tgz -C /root/.DONOTRUN/3ware_diagnostics/  and press enter.
     
  6. Proceed to Section 3.

     

Section 3
Create the archive file containing 3Ware RAID Controller Logs...

  1. First change directory to the file path where lsigetlunix.sh resides. The file path will either be as you found it in Section 1 - step 3a above, or it will be as you created it in Section 2, step 4.
    *example:  cd  /root/.DONOTRUN/3ware_diagnostics
     
  2. Execute lsigetlunix by typing  ./lsigetlunix.sh  and press enter, then type capital C when prompted and wait for the script to complete.

     
  3. After script completion, take note of the archive file that was created, then type capital Q to quit.

    note: In this example the archive file is named lsi.linux.NSM129.062613.1600005.tar.gz.



Section 4
Copy the archive file onto the desktop.

  1. From Pelco Utilities, right click the unit and select SCP > Copy files from.

     
  2. At the Remote Path prompt, enter the file path and archive file from earlier Sections...

     

     
  3. Next, select a folder such as Desktop to save the archive file to and click OK...  

     
  4. Optionally - if directed by Product Support - follow LL#17762 to also gather the 3Ware RAID Controller Performance Monitoring Statistics.
     
  5. Send the archive file and the 3Ware RAID Controller Performance Monitoring Statistics to Pelco Technical Support for examination as directed.