Issue
Does Niagara G3 provide a way to resend an alarm to an email until it get acknowledged?
Environment
Niagara G3, ENS, ENC_520, ENC-410
Cause
Want to keep sending an alarm notification email until it is acknowledged.
Resolution
Niagara G3 has a property called Escalation Level# which is located in the Alarm Class object. Alarm escalation is a feature that allows you to configure an alarm class so that unacknowledged alarms that are assigned to that class can be re-routed if they are not acknowledged within a specified amount of time.
When enabled, this property allows for resending of an alarm notification if the alarm has not been acknowledged. The unacknowledged alarm notification can be resent up to 3 times. The EmailRecipient would be linked to a designated Alarm Class which is setup for email notifications you want to re-send until they are acknowledged.
1. Open the designated Alarm Class
2. Set the three “Escalation Level# Enabled” to “true”.
3. Set the three “Escalation Level# Delay” times to the time you want to what before the notification and therefore email is resent.
4. Save changes and then open the Wire Sheet that the Alarm Class is located on
4 Connect each of the output of the Escalated Alarms to the EmailRecipient
(You can connect all the Escalated Level output to the same EmailRecipient or multiple email recipients.)
Again, the Alarm Class can be configured to send a notification up to a total of 4 times until acknowledged - the initial first notification email and 3 re-send of the notification if the alarm has not been acknowledged. No further notification will be sent once the alarm is acknowledged.