ECC Errors on the NSM5200 / DSSRV / DSSRV2

NOTICE

POTENTIAL FOR DATA LOSS.
The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure, please contact Product Support Services prior to attempting the procedure below.

NOTICE

COMPLEX PROCEDURE REQUIRED.
The resolution of this article has many complex steps that may result in unforeseen results if not performed correctly. If you are at all unfamiliar with the requirements, please contact Product Support Services for assistance.

Issue

When checking the status of the hard drives in tw_cli one or more drives shows a status of ECC Error.

Product Line

Pelco Video Management

Environment

  • Endura NSM5200 all versions
  • DSSRV / DSSRV2
  • 3Ware SAS 9750-8i RAID Controller (LSI)

Cause

An error when reading back data; possibly caused by missing or erroneous bits.

Resolution

To set the 3Ware Controller to ignore ECC Errors so that the NSM5200 can rebuild failed drives:

  1. SSH into the unit using username: root and password: pel2899100
  2. Enter tw_cli
  3. Enter show
  4. Take note of the CTL number
  5. Enter the following command changing the X to represent the CTL number: info cX  (This will show the status of the array.)
  6. Enter /cX/u0 set ignoreecc=on
  7. Enter maint rescan
  8. Verify drive status: info cX


Note:  DSSRV / DSSRV2 - Ignore Step 1, steps 2 - 8 are run in an elevated windows command prompt.