Unable to delete an LNS database or other protected object from Vista

NOTICE

POTENTIAL FOR DATA LOSS.
The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure, please contact Product Support Services prior to attempting the procedure below.

Issue

Some objects are protected by default in Vista requiring that changes be made to the authorities of the object in order for it to be deleted. Protected database objects will be in gray text whereas unprotected objects are in black. Additionally, the Delete option when right-clicking a protected database object will be grayed out.

Text on protected database objects is gray

 

Text on objects that are not protected are black

Product Line

TAC Vista

Environment

Vista Workstation

Cause

Even though administrators have full control to read or write any database objects, some objects are protected so that they are not accidentally deleted. An administrator must remove the protection before deleting the object.

Resolution

Ensure that you are logged into Vista as an administrator then perform the following steps to delete a protected database object:

  1. Right click the protected database object and select Authority.
  2. In the Authority dialog box check Change access level on subunits and Change access level on existing objects.



  3. The two check boxes for Require signature on database object change and Protected database object at the top of the dialog box will likely change from check marks to dark boxes. Click on these boxes until they are empty.


     
  4. Click OK.


     
  5. Refresh the window by pressing F5 or clicking the refresh button. The database object should now have black instead of gray text and can now be deleted.