DS Video Server Service Startup Error 1011 after 4.2.0 (6.8.0.276) Recovery is performed.

NOTICE

COMPLEX PROCEDURE REQUIRED.
The resolution of this article has many complex steps that may result in unforeseen results if not performed correctly. If you are at all unfamiliar with the requirements, please contact Product Support Services for assistance.

NOTICE

DISCONTINUED PELCO PRODUCT.
This product has been discontinued. For further information please visit pelco.com/support/discontinued-products

Issue

When a 4.2.0 recovery was ran on a DS DVR and a 4.2.2 DB was used to restore configuration, the Video Server Service will not start and will give you "Startup Error 1011"

Product Line

Pelco Video Management

Environment

DS DVR (DS Xpress, DS RealVUE, DS1000, DS NVR)

Cause

The database used in 4.2.0 is different than the database used in 4.2.2. The 4.2.0 software does not know how to handle the 4.2.2 database which results in the "startup error 1011"

Resolution

To resolve this issue, upgrade the DS Software to 4.2.2. This can be done by performing the following.
1. Close all DigitalSENTRY programs.
2. Stop all DigitalSENTRY services.
3. Download the 4.2.2 software packages from the following links. 

Server/VAU 6.8.2.22 and  DSClientAdmin 6.8.2.22

4. Unzip both of the downloaded files. 
5. Run the setup.exe for both downloads and follow the steps on the screen.
6. Once both updates are installed, reboot the DVR and the Video Server Service should start properly.