How to repair Endura SM5000/SM5200 User Role Permissions.

Issue

Issue may include one or more of the following symptoms -

  • Some or all permissions missing when configuring WS5000/WS5200 User Roles.
  • Specific Users unable to login, or missing devices or functions after logged in
  • PTZ control fails for specific users.  For this issue, also see LL#11759
  • Unable to create new users for a given role, whilst others still function.
  • User cannot access "Quick Search" or "Enhanced Search" Results via Endura WS5000 Management Software while at least one user can.

Product Line

Pelco Video Management

Environment

  • WS5000/WS5200
  • SM5000/SM5200

Cause

System manager Permissions Database contains data corruption.

Resolution

  1. Ensure WS5000/WS5200 software is closed/exited, then launch Endura Utilities and log in as admin.
    note: The default user credentials are admin/admin, if this has changed or become corrupt, contact Pelco Endura Support @ 800 289 9100 for assistance.
  2. Press the Search and then SM Search buttons at lower-right of Endura Utilities.
  3. Select the SM5000 or SM5200 Category from the leftside-panel within the System Attributes tab.
  4. Within the rightside-panel, Right click on the SM5000 or SM5200 and navigate to Scripts and select SM Check Indexes.
  5. Select Yes on the "Are you sure?" Popup Dialog, and then select Close once the script has finished running.
  6. Again from within the rightside-panel, Right click on the SM5000 or SM5200 and navigate to Scripts and select SM Fix Indexes.
  7. Select Yes on the "Are you sure?" Popup Dialog, and then select Close once the script has finished running.
  8. Again from within the rightside-panel, Right click on the SM5000 or SM5200 and navigate to Scripts and select SM Permissions Fix.
  9. Select Yes on the "Are you sure?" Popup Dialog, and then select Close once the script has finished running.
  10. Launch WS5000/WS5200 and check for issue resolution.