Cannot see the camera's name in DS ControlPoint when connect as a limited user

Issue

The cameras can be dragged into the view window okay, just cannot see the camera's name in DS ControlPoint when connected as a limited user. It works fine from same client when using an admin account for credentials.

Product Line

Pelco Cameras, Pelco Video Management

Environment

  • DS ControlPoint version 7.1.47
  • DSSRV version 7.4.320
  • Limited user (limit to "Live Video" under User Rights)

Cause

When it comes to the database for version 7.1, there were certain fields available for User permissions where as for version 7.3 and newer systems, those fields within the database changed and were added to instead of decreased. So, when you try to connect from either an older/newer DS ControlPoint version to the newer/older (respectively) DigitalSentry versions, you get the database mismatch.

Resolution

The problem with User Interactivity with the system from within DS ControlPoint is due to a mismatching of database versions and capabilities.

Upgrade to Digital Sentry software version 7.4.363 or greater.

Related Articles:
Where can I download the latest version of Digital Sentry software
How to upgrade the Digital Sentry Software Suite on DSSRV / DSSRV2 / DS NVs HVR(s) and NVR(s).