Sarix cameras will not update firmware

NOTICE

POTENTIAL FOR DATA LOSS.
The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure, please contact Product Support Services prior to attempting the procedure below.

Issue

Sarix cameras will not update from any version

Product Line

Pelco Video Management

Environment

All Sarix models versions 1.9.2 and lower

Cause

Sarix cameras will not update due to internal service moving to the next step in extraction process before it finishes previous functions.  The process times out.

Resolution

1. Log into Endura Utilities using your admin login [Default username: admin, password: admin]

2. Right click the device in Endura Utilities and select SSH into [Default username: root, password: pel2899100]

3. Edit the fwupdate file by entering  vi /usr/sbin/fwupdate

4. In the vi editor press the i key to switch to INSERT mode.

5. Navigate to line 90 of the file (Note: if your camera is running 1.3 or lower, use line 80) (On 1.9 see example in step 7)

6. Add the following line: sleep 30

7. Make sure to align the spacing so it lines up with the other commands. The file should look similar to the following:

On 1.7 and below

# /bin/df -h
log_status "Downloading update package..."

sleep 30

/usr/bin/wget ${URL} -P ${EXTRACTDIR}
I /usr/sbin/fwupdate [Modified] 90/231 38%

On 1.9.2

check_running_procesess

sleep 30

             get_ppm_pakages

 

8. Leave INSERT mode by pressing the Esc key.

9. Save and quit out of the vi editor by entering :wq (To close without saving enter :q!)

10. In Endura Utilities right click the camera and select Device Actions (or Device Macros with older versions of Utilities) 

11. Select Update

12. When prompted with "Update is complete", click the OK button.

Note: This update process can take several minutes to complete.