Issue
We are unable to connect to a Niagara G3 ENC-520 whose IP address was incorrectly set. How can the IP address be determined and changed if there's no access via its Ethernet port?
Environment
Niagar Workbench, ENC-520, ENC-410
Cause
Incorrect entry of the IP Address or subnet mask can cause the ENC to appear unresponsive to WorkBench software.
Resolution
There are two methods available to determine the IP address and subnet mask entered for the ENC.
The first method requires having access to the computer used to change the IP address of the ENC. Your Workbench PC records the “before and after” TCP/IP settings made from Niagara platform connections in a a file called "ipchanges.bog". You can review changes from Workbench using the following procedure.
Do the following in Workbench:
1. In the Nav tree, expand “My Host” and then “My File System.”
2. Expand “Sys Home” and then “users.”
3. Expand your user folder, then expand “ipchanges.bog.”
Child folders are “date-named” using the following convention:
d
4. Expand any folder of interest. Underneath each folder are two objects:
• priorValue — TCP/IP settings that existed before this change.
• newValue — TCP/IP settings that existed after this change.
5. Double-click a priorValue or newValue to see settings in the “Tcp Ip Host Editor” (see Figure).
The second method requires the use of a terminal program, an UNCC-405 to adapt RS232 to RJ45, and a CBL-RJ45 cable (a standard Ethernet cable no longer than seven feet will do). The HyperTerminal program is used to directly connect to a ENC-520 to verify and to make changes to its IP address in order to make it accessible. HyperTerminal makes it possible to view the ENC's configuration and execute limited commands.
Reference the section “Using serial system shell”, located in Chapter 1 of the Niagara AX Install & Startup Guide, on how to directly connect to ENC using HyperTerminal. After connecting to the ENC, use the procedure "Updating Network Settings", which is located in the same Chapter of the guide, to display and/or change the IP address or subnet mask.
Failure to enter the subnet mask properly can prevent the UNC from being seen by WorkPlace Pro.