Gateway does not show any transcoders attached.

Issue

The Gateway does not recognize some/all of the transcoders.

Product Line

Pelco Video Management

Environment

  • Endura GW5000: All versions
  • Endura NET5301-TC: All Versions
  • Endura SM5000: All Versions

Cause

Transcoders that are not synced and registered to the SM will not appear in the Gateway database.

Resolution

  1. Ensure that the Transcoders are synced and registered to the SM via the System Attributes tab in Endura Utilities.
  2. If they are not, see Lessons Learned Article #8858 to reset sync and security on them. If they are synced and registered continue to step 3.
  3. Right click on the GW5000 in Endura Utilities and choose SSH into. [Username: root | Password: pel2899100]
  4. From the root prompt enter: psql -Upostgres Gateway
  5. From the Gateway prompt enter: select * from "Transcoder";
  6. The following screenshot shows what an empty table would look like. This indicates that the Gateway does not see any transcoders.

  7. Enter \q to exit the Gateway database.
  8. To flush out the database and force the unit to pull new information from the SM regarding transcoders, do the following.
  9. Stop the GW5000 service: service gw5000d stop
  10. Enter: cd /usr/local/Pelco/GW5000/Other/Database
  11. Run the resetgwdb script:  ./resetgwdb
  12. Reboot the unit: reboot