How to SSH into an Endura Device

Issue

SSH is vital to proper maintenance and troubleshooting of Endura System Devices.

Product Line

Pelco Video Management

Environment

  • Microsoft Windows PC
  • 1 or more Linux-based Endura components

Cause

Troubleshooting issue(s) with Endura Device(s) often requires remotely accessing the device via SSH.

Resolution

  1. Launch Pelco Utilities (formerly Endura Utilities), log-in and press the Search Button, wait for that to finish, then press the SM Search Button.
    note: The default login credentials for Endura Utilities versions 2.2 and below is [Username: Administrator and Password:configapp], while version 2.3 and greater instead authenticate against the Endura SM5000 or SM5200 System Manager instead ( Username:admin and Password: admin from factory).
     
  2. From the System Attributes tab, left-click a Device Model, then right-click a specific Endura Device from right-side panel and select SSH into...


    Note: The default Linux Administrative login credentials for Endura devices are [Username: root and Password: pel2899100 ].


    Note: If you receive the following error...

    ...Visit http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html to download the Putty Installer (putty-0.65-installer.exe). Proceed to installing putty. Once putty is installed, follow the instructions here(http://www.howtogeek.com/118594/how-to-edit-your-system-path-for-easy-command-line-access/) and add "C:\Program Files(x86)\putty\" to your PATH variable.

    Note: If the PC has never SSH'd into the unit before, you will receive the following warning prompt...

    ...simply click Yes to proceed.

    Note: If you receive the following error...

    ...The device may not be accessible on the network (attempt right-click > continuously ping to verify) or SSH may not be enabled. To Enable SSH for Sarix Cameras/Encoders, see LL#11444. To Enable SSH for Spectra IV IP or Spectra Mini IP, see LL#12025.