No PTZ control of Pelco Spectra IP cameras in DS Admin or DS ControlPoint.

Issue

The Pelco Spectra IP or HD camera does not move when control commands are selected.

Product Line

Pelco Cameras, Pelco Video Management

Environment

  • Digital Sentry software
  • DS ControlPoint
  • DS Admin
  • DSSRV
  • DS NVs
  • Spectra IV IP
  • Spectra HD / Spectra Pro / Spectra Enhanced

Cause

The incorrect protocol is selected for PTZ Type: Pelco SpectraDome.

Resolution

Verify the correct protocol Pelco SpectraIP is configured in DS Admin for IP camera PTZ control.

  1. Open DS Admin (Start > All Programs > Pelco > DS Admin)
  2. Login with an administrator account.
  3. Expand the Cameras folder
  4. Click on the PTZ tab.
  5. Click on the PTZ IP camera in the list.
  6. Check "Enable PTZ support for this camera".
  7. Click the Get Types button.
  8. Click the drop down menu next to PTZ Type: and select Pelco SpectraIP.
  9. Click Save.

    NOTE: If PTZ control fails to work after saving the settings, close DSAdmin and manually restart Digital Sentry Video Server Service.
    Related link: How to start/stop Digital Sentry Services.



    Note: The Protocol and Address options are not used with the Spectra IV IP or HD cameras.