DS RealVue displays no live video after installing/upgrading the Digital Sentry software.

NOTICE

DISCONTINUED PELCO PRODUCT.
This product has been discontinued. For further information please visit pelco.com/support/discontinued-products

Issue

The DS RealVue is unable to connect to the MP3000 capture cards after upgrading the software.

Device Manager displays (!) next to either the MP3000 or ECPR240-8.

Product Line

Pelco Video Management

Environment

  • DS RealVue  7.1.47
  • DS RealVue RAID 7.1.47

Cause

The software install/upgrade process did not properly install the MP3000 capture card drivers.

Resolution

 

  1. Download the DSRealVue MP3000 Drivers.zip file and copy to the desktop of the recorder.
     
  2. On the recorder, stop the following DigitalSENTRY Services:
    • DigitalSENTRY WatchDog Service (if running)
    • DigitalSENTRY VideoServer Service
    • DigitalSENTRY Storage Service
       
  3. Open Device Manager (right-click My Computer > Properties > Hardware > Device Manager) and expand DVR-Devices.
     
  4. Right-click on any MP3000 or ECPR240-8 entries with exclamation points next them (!) and select Uninstall.  Remove all entries with the (!) next to it.
     
  5. Minimize Device Manager.
     
  6. Navigate to C:\Windows\System32\Drivers
     
  7. Locate the following files:
    • ECPSV.sys
    • ECPSVD.sys
    • MPJVS.sys
       
  8. Rename the files with the extension .BAK (e.g. ECPSV.sys.bak)
     
  9. Copy the downloaded .sys files from the DSRealVue MP3000 Drivers folder to the C:\Windows\System32\Drivers folder.
     
  10. Once all files are copied over, maximize the Device Manager window.
     
  11. In Device Manager click on the Action menu and then select Scan for hardware changes.
     
  12. The "Found New Hardware Wizard" will appear, select Install from a list or specific location (Advanced) and click Next.
     
  13.  Select Don't search. I will choose the driver to install and click Next.




     
  14. Select the driver listed in the Show compatible hardware and click Next.




     
  15. A "Files Needed" window will appear, click the drop down arrow for the Copy files from: field and select C:\Windows\System32\Drivers




     
  16. Click OK and then Finish to complete the installation.
     
  17. Repeat steps 12 - 16 for each additional driver detection/installation prompt.
     
  18. Once all drivers are installed, verify in Device Manager that all ECPR240-8 and MP3000 drivers are listed and show to be installed correctly.
     
  19. In Services, start all of the DigitalSENTRY services which were stopped in Step 2.
     
  20. Open DS Admin and verify in VAU > VAU [system name] > VAU Info tab that the selected "Video Input Devices" are MP3000. 
     
  21. Expand the Cameras folder in DS Admin, click on the camera to load it's configuration tabs, select the On Screen Display tab and verify live video.