A rapid, possibly loud, clicking noise from a Genex Multiplexer.

DANGER

HAZARD OF ELECTRIC SHOCK.
Remove all power from all devices before removing any covers or doors of the system. Disconnect the power at the device and at the power source.

WARNING

ELECTROSTATIC DISCHARGE REQUIRED.
Discharge all static electricity from your person by touching metal prior to handling any hardware. Failure to do so may result in damage to devices.

NOTICE

POTENTIAL FOR DATA LOSS.
The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure, please contact Product Support Services prior to attempting the procedure below.

NOTICE

COMPLEX PROCEDURE REQUIRED.
The resolution of this article has many complex steps that may result in unforeseen results if not performed correctly. If you are at all unfamiliar with the requirements, please contact Product Support Services for assistance.

NOTICE

DISCONTINUED PELCO PRODUCT.
This product has been discontinued. For further information please visit pelco.com/support/discontinued-products

Issue

  • I lost video from my Multiplexer and I hear a clicking noise; is this a sign of it going bad?
  • I hear a click noise from my Genex Multiplexer; what does this mean?
  • What does it mean when the Multiplexer has a rapid clicking noise happening inside?

Product Line

Pelco Video Management

Environment

  • MX4004 - MX4004CS, MX4004CD, MX4004MS, MX4004MD
  • MX4009 - MX4009CS, MX4009CD, MX4009MS, MX4009MD
  • MX4016 - MX4016CS, MX4016CD, MX4016MS, MX4016MD

Cause

Audible and internal clicking noise emanating from the Genex Series Multiplexers.

Resolution

Usually what the clicking noise means is that the power supply has gone bad and needs to be replaced. The part number for ALL Multiplexer models is PS01-0045-0005G. This is usually accompanied by ALL LEDs flashing on the front of the unit.

Pelco recommends sending the unit into a local service center for repair. Product Support cannot assist with component level procedures.

See Lessons Learned Article #11086 for sending in for Pelco Repair.