How to verify that cameras are recording on an NSM5200 via nsterm

Issue

How to verify that cameras are recording on an NSM5200 via nsterm

Product Line

Pelco Video Management

Environment

Endura NSM5200- All versions

Cause

It is necessary to verify that cameras are recording via nsterm.

Resolution

  1. Launch Endura Utilities, log in and press Search.
    note:  The default login credentials for Endura Utilities version 2.2 and below is [Username: Administrator and Password: configapp], however version 2.3 and greater removed that unique login credential requirement, and instead authenticates against the standard Endura Credentials. The default login in that case is [Username: admin and Password: admin].
  2. Locate the NSM5200 in question.
  3. Right click on the NSM5200 and choose SSH into. [Username: root and Password: pel2899100]
  4. Type nsterm and hit Enter.

  5. A Connection Selection window should appear, if it does not type find and hit Enter.

  6. Enter the ### directly to the left of the nsd associated with the IP of the NSM that needs to be checked. In this example it is 3. Hit Enter.
  7. Enter the letter c to display all of channels currently being recorded by the SM. note: If anything other than Record is shown for a camera, the camera is not recording.

    Here are the different states a channel will display:
    CAPFAIL  Capture failed
    NOCAP  Capture disabled
    OFFLINE  Offline
    CAPTURE  Capturing. This is often seen when the cameras are set for motion recording, but the motion alarm has not been triggered.
    RECORD  Recording
    CAPPEND  Capture pending. The NSM5200 is attempting to capture on the channel.
    RECPEND  Record pending
    The TMUA heading stands for "timed, motion, manual, alarm." Timed is another name for "continuous." There may be either an asterisk (*) or plus sign under one or more of the letters. An asterisk means that it is recording. A plus sign means that it is recording due to a post-alarm.
     
  8. To exit nsterm, type the word exit and hit Enter.
  9. To determine which camera a specific channel is referring to highlight the uuid portion under Channel ID as shown below. (The uuid will be copied to the clipboard by just highlighting it.)

  10. Paste the UUID into the Filter box in Endura Utilities as shown below. note: If Utilities does not show a filter box it will need to be updated.