Pelco Mobile does not connect to a Digital Sentry NVR behind a Router/Gateway.

Issue

Pelco Mobile fails to connect to a Digital Sentry NVR behind a Router/Gateway

Product Line

Pelco Video Management

Environment

  • Digital Sentry
  • DSSRV
  • DSWebService
  • Pelco Mobile Application

Cause

The network port TCP 443 is not accessible or is already in use.

Resolution

When using Modem/Router/Gateway equipment from an ISP (Internet Service Provider), the devices behind the modem will use private IP address (e.g. 192.168.x.x or 172.16.x.x or 10.x.x.x.) 
In order for the Pelco Mobile application being used on the public network to connect to a Digital Sentry recorder which is behind the modem/router on the private network, you will need to configure a Port Forward of network port TCP 443 from the Public (WAN) side to the internal private (LAN) side in the modem/router setup page.

Refer to your Routers configuration documentation on how to configure a Port Forward.  Here is a website which may have port forwarding configuration information for your router model (not affiliated with Pelco or Schneider Electric, warning - heavy advertisement) http://portforward.com/english/routers/port_forwarding/routerindex.htm

Note: Make sure the features Remote Management, Remote Access or Remote Administration are disabled in the routers configuration, these features tend to use TCP 443 for a secure connection which will conflict with the Port Forward created.