UDI5000-MTRX MAC, Version , Reg, Sync status is blank when viewing in Endura Utilities.

Issue

Endura Utilities does not properly display the status of the UDI5000-MTRX but operates as expected.  Rebooting the UDI5000-MTRX does not resolve the issue.  Symptoms in Endura Utilities include but may not be limited to:

  1. UDI5000-MTRX MAC address is blank
  2. UDI5000-MTRX Version is blank
  3. UDI5000-MTRX SM State is Online
  4. UDI5000-MTRX Synced is blank
  5. UDI5000-MTRX Registered is blank
  6. UDI5000-MTRX may show up as a Non-Endura device

Product Line

Pelco Video Management

Environment

  • UDI5000-MTRX All Versions
  • Endura Utilities All Versions

Cause

The UDI5000-MTRX proxy service is a simple http proxy. The UPNP services (control, event, and a fileserver) are separate python services listening on different ports. However, it can only advertise as one service. So, it advertise the proxy service which looks at the incoming URL and forwards the traffic to the appropriate internal service. The UDI5000-MTRX proxy service may at times be required to restart to operate properly.

 This may occur after updating the UDI5000-MTRX or reimaging the UDI5000-MTRX.

Resolution

  1. Log into Endura Utilities with the default credentials username admin and password admin
  2. Select the System Attributes tab then click on SM Search in the bottom right
  3. Select the UDI5000-MTRX from the right pane
  4. Right click on the UDI5000-MTRX from the left pane then select SSH Into
  5. Login root and password 2899100
  6. Type service proxy restart then press Enter

      7.  Wait 1-2 minutes then click on SM Search again.  Refreshing the device info may be required (Ctrl+R)