DS ControlPoint errors when connecting to a Digital Sentry system with A network-related or instance-specific error occurred while establishing a connection to SQL Server.

Issue

DS ControlPoint client machine errors with the following error when attempting a connection:

Error connecting to one or more of your systems. A network-related or instance-specific error occurred while establishing a connection to SQL Server.  The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)



 

Product Line

Pelco Video Management

Environment

  • DS ControlPoint 7.3.208 and above
  • DSSRV
  • DS NVs

Cause

DS ControlPoint is unable to communicate with the SQL network port on the Digital Sentry recorder. 

This can be due to:  

  1. A public internet connection.
  2. NAT router configuration.
  3. Firewall configuration. 
  4. This can also happen if the incorrect IP address is used when creating the site in DS ControlPoint.
  5. If the Digital Sentry recorder is offline/SQL Server (DS_MSSQLSERVER) Service not running.
  6. Corrupted MSSQL Data log
  7. If SQL Server Browser Server is not Started.

Resolution

  1. Verify the IP address/hostname used for the DS ControlPoint System matches the connection IP address/hostname on the recorder.
    1. In DS ControlPoint, click on the Systems tab
    2. Right-click on the connect site and select Edit System
    3. Document the information listed under "Hostname or IP Address:"
    4. At the Digital Sentry recorder, open DS Admin (Start > All Programs > Pelco > DS Admin).
    5. Login with the 'admin' user account (or another account Manager user rights).
    6. Expand the VAU(s) folder and then click directly on the system name with the computer icon to open the VAU configuration tabs.
    7. Click on the VAU Info tab and verify the information listed under TCP/IP Address.
      On a LAN (local area network), the VAU Computer Name or TCP/IP Address should match what is used in the DS ControlPoint client.



      Note: If using multiple network adapters on the recorder, use the IP address of the NIC with the company/client network subnet.
       
  2. Verify the SQL Server (DS_MSSQLSERVER) service is started and running.
    1. Open services (Start > Search Bar/Run and type in services.msc)
    2. Verify the "SQL Server (DS_MSSQLSERVER)" service shows a Status of Started.
    3. May also want to verify the DigitalSENTRY VideoServer Service and the DigitalSENTRY Storage Service are also Started.
       
       
  3. Ping the recorders hostname or IP address to determine network connection.
    1. Open a command prompt (Start > Search Bar and type in cmd and press ENTER)
    2. At the command prompt type in Ping {hostname/IP Address} and press ENTER.
      Example: ping 192.168.0.100
    3. Verify the you receive reply's from the ping request.
      If you receive "Request timed out", verify the network connection is correctly plugged in and linked at the DVR as well as double check the IP address.



       
  4. Use Telnet to test the Digital Sentry recorders SQL and Video network ports.
    1. On the client PC running DS ControlPoint, verify Telnet Client is installed (Start > Search Bar, type in Turn Windows features on or off and press ENTER)
    2. Place a checkmark for Telnet Client and click Ok.
    3. Once the Telnet Client has been installed, open a command prompt.
    4. Use the command telnet {IP address} {network port} and press ENTER.
      Example: telnet 10.117.24.189 49166 
      Application Port Information on Digital Sentry network port usage, refer to article: What are the known open network ports for the Digital Sentry (DSSRV) System?

      A successful connection will result in a blank command prompt with a blinking cursor, this means the network port tested is open and listening on the DVR.




      If the network port is unavailable either due to a firewall/router, wrong port used or the system is not online, you will receive a connect failure.


       

       
  5. Check the SQL Server Browser service, verify Started.
    At the Server:

          1. Open Computer Management.
          2. Expand Services and Applications.
          3. Double click Services to open Services list.
          4. Scroll down to locate SQL Server Browser.
          5. Restart service. 




     

Related Articles:
What are the known open network ports for the Digital Sentry (DSSRV) System?

DS ControlPoint: Connect to a Digital Sentry DSSRV / DSSRV2 behind a router, firewall or through Network Address Translation (NAT).