DX Mobile App fails to connect to DX4700/DX4800(HD).

Issue

DX Mobile App displays a Failed to connect loop.
Sequence 1


Sequence 2 

 

Sequence 3

Product Line

Pelco Video Management

Environment

  • DX4700 Non HD version 1.02 and higher
  • DX4800 Non HD version 1.02 and higher
  • DX4700HD (version 2.0)
  • DX4800HD (version 2.0)
  • DX Mobile App

Cause

  • RTSP (554 default) Port is block.
  • RTSP (554 default) Port is not matching on Devices.

Resolution

Check the RTSP port setting on the DX Mobile app is matching to what was enter in the DX4700/DX4800.

  1. Open the DX Mobile app.
  2. Connect to DX4700/4800 listed in the Device List.
  3. Select Edit Device.
  4. Confirm RTSP port number enter matches to what was enter in the DX4700/DX4800 server.
  5. On DX4700/4800 server Select Setup icon.
  6. Select System.
  7. Select Network.
  8. Confirm RTSP port.

Check RTSP port is open on the router.