Issue
How can the priority as set in the Event Notification be used to sort alarms?
Environment
Cyberstation all versions.
Cause
The Priority of an alarm is not stored in the Alarm log.
Resolution
To sort the Active Alarm view by priority: In the Active Alarm view, from the top menu select View, Sort.
This will open the sort criteria for the active alarms. There are 3 levels of sort:
Primary, Secondary & Tertiary. by default these are Datetime, Name & Value.
For Historical alarms in a list view, the Priority of an alarm is not recorded in the Alarm Event table database, so you cannot filter or sort on Priority when looking at historical alarm logs.
Note: The Priority is read from the Event Notification table for use in the live alarm window.