How to get a copy of the model number, firmware version and configuration (a.k.a. show tech) of an Ethernet switching or routing device

Issue

Configuration of an Ethernet switching or routing device needs to be reviewed offsite as part of the troubleshooting process, for the following issues: no communication between devices, intermittent communication between devices, no video, no security key exchange, no Multicast routing (flooding or blocking of Multicast packets), high packets latency.

Product Line

Pelco Cameras, Pelco Video Management, Pelco Transmission & Power

Environment

Ethernet LAN Infrastructure with a configured console or remote access connection.

Cause

Logging of the Ethernet device configuration is desired for further analysis.

Resolution

Note: The following procedure requires the use of putty.exe. If this software is not already installed on the PC used to access the Ethernet device, please visit http://www.putty.org/ to download and then copy putty.exe into your workstation c:\windows\system32 folder. Alternatively, Putty can be copied into another folder that is in Path variable of the Environment Variables (e.g., c:\windows).

1.  Launch putty.exe and configure the settings for the Connection Type (contact the network administrator if you don't already have this information). Usually an SSH or a Serial connection:

or

 

2. Click on Logging and configure the settings to allow the printable output to be saved in a file:

 

3. Click on Open to initiate the connection and get to the login prompt:

Note: You might be asked for a password. Contact the network administrator if you don't already have this information.

 

4. Type enable then press Enter to move to the privileged EXEC (enable) mode:

Note: You might be asked for a password. Contact the network administrator if you don't already have this information.

 

5. Type show tech-support then press Enter:

 

6. The information will be scrolling on the screen and will be logged in the specified file at step 2. Be patient, it could take a few minutes to complete.

 

7. Once completed, you should have a text file similar to the following example done on a Cisco Catalyst 3750.

 

8. For more information about the show tech-support command, visit the related Cisco IOS Configuration Fundamentals Command Reference page.