How to configure the DX4100 Series for network access.

Issue

Connect DX4100 to network.

Product Line

Pelco Video Management

Environment

  • DX4104 Series DVR

Cause

New installation of the DX4100.

Resolution


Default client connection ports:

  • HTTP (Web interface) = TCP 80
  • Video Port / DX4100 Client Software = TCP 9001



Login: admin/admin for username and password.

Click on SETUP; and click on NETWORK

NETWORK MENU

You must configure the DVR network settings to use the following features:

Client software application: Allows you to operate and administer up to sixteen DX4104 servers. The DX4104 server supports up to five simultaneous connections when using the client and Web client applications. For more information about the remote client software application, refer to the DX4104 Client Operation/Configuration manual.

Web client application: Allows you to use a Web browser to view live video and operate PTZ features of cameras attached to a DX4104.

You can remotely monitor up to 16 cameras from the Web client application.

Software update over the network: Allows you to update the server software over the network.

Network Time Protocol (NTP): Allows you to use a public or private time server.

Mail notification: Sends e-mail notification when an event is detected (alarm, motion, disk full, administrator password change, video loss, or when the unit is turned off and on).

Emergency Agent: When the unit detects an event (alarm, motion, disk full, administrator password change, video loss, or the unit is turned off and on), a warning message is sent to the remote computer. The message displays for five seconds in the lower-right corner of the remote client PC screen. The unit must be turned on and

connected to a network, and you must be logged on at the administrator level, to configure network settings. You must restart the DVR for the network configuration changes to take effect. Therefore, do not change network settings unless unit recording can be interrupted.

TCP/IP SETUP

The unit by default is configured to use Dynamic Host Configuration Protocol (DHCP). If a DHCP server does not reside on your network, the unit allows you to use a static IP address. If the DHCP setting on the TCP/IP menu is set to OFF, you can configure the following settings:

IP Address: Enter the static IP address (if used by your network).

Subnet Mask: Enter the IP address of the subnet mask.

Gateway: Enter the IP address for the Internet gateway server. On smaller systems, this will be the IP address of the DX4104. On larger systems, there might be a gateway server.

Primary DNS Server: Enter the IP address of the primary Domain Name System (DNS) server that the DX4104 will use to convert names to IP addresses. If you are using the DDNS server, you do not need to enter a DNS server.

Secondary DNS Server: Enter the IP address of the backup DNS server that the DX4104 will use. This server is used if the primary DNS server fails.

TCP/IP Port: Enter the port number. The default port number is 9001.

Web Server Port: Enter the port number that the Web client will use to communicate with the DX4104 over the Internet. The default port number is 80.

NOTE: If you use the Web client to access the unit and you change the port number, you must include the new port number with the IP address or the Web address. For example, the revised IP address would be http://192.168.0.40:8080, where 8080 is the revised port number.

Bandwidth Throttle: Select the network bandwidth throttle to limit the amount of network resources allocated to client connections.

The default bandwidth throttle is 100 Mbps.

To set up TCP/IP:

1. From the Setup menu, click Network.

2. Click TCP/IP.

3. Select the DHCP setting.

ON: Use a DHCP server. Skip to step 5.

OFF: Use static IP address settings. Continue with step 4.

4. Click the boxes to enter their settings.

5. Click Close.

6. Click OK

 

DDNS SETUP

The DDNS feature uses the services provided by No-IP™. Prior registration with No-IP to obtain a user name and password is required before configuring the DVR.

The DDNS feature uses port 8245 provided by No-IP. If the DVR is installed in a network that has a firewall, port 8245 has to be open to allow DDNS data to get through the firewall. For information about setting up the firewall, refer to your network administrator or network service provider. The unit allows you to configure the following DDNS

settings:

User Name: Assigned the DDNS server provider during registration.

Password: User password. Assigned the DDNS server provider during registration.

Host Name: Obtained from the DDNS server provider.

To set up DDNS:

1. From the Network menu, click DDNS.

2. Click the boxes to enter their settings.

3. Click Update. The system searches for and registers the unit with the DDNS server.

4. Click OK, and then click Close.

NOTIFICATION SETUP

The notification feature has the following guidelines if the setting is ON:

Alarm: Sends an alarm notification in response to an alarm event.

Motion: Sends a motion notification in response to a motion event.

Disk full: Sends a disk full notification if the Hard Disk Overwrite setting is not set to OFF.

Admin password changed: Sends an administrator 01 ID notification in response to a change to the 01 ID administrator password.

Changing the password of additional users assigned administrator-level permission will not initiate a notification message.

Video loss: Sends a video loss notification in response if video loss is detected on any channel.

Power on/off: Sends a power loss notification in response to the DX4104 power being turned off.

To set up notification:

1. From the Network menu, click Notification.

2. Click the boxes to enter their settings.

3. Click OK, and then click Close.

4. Click OK again.

MAIL SETUP

The mail feature sends an e-mail text notification to all designated users when an event is detected. Use the notification option to configure an event to trigger an e-mail notification. For information about configuring the notification option, refer to Notification Setup on page 43. The mail feature is configured and operates independently of the

emergency agent feature. For information about setting up the emergency notification feature, refer to Emergency Notification Setup on page 44. The unit allows you to configure the following mail settings:

Notification: Turns the notification feature on and off.

TLS: Select ON to use the Transport Layer Security (TLS) feature. By default, TLS is not enabled.

SMTP Server: Enter the Simple Mail Transfer Protocol (SMTP) server IP address or host name. Supports up to 24 characters including

0.0.0.0 to 255.255.255.255, a to z, A to Z, numerals 0 to 9, and special characters.

SMTP Port No.: Enter the SMTP port. The default TCP/IP port used for SMTP is 25. Supported values are 25 and 1025 to 65535.

User Name: Name of user to be notified. Supports up to 24 characters including 0.0.0.0 to 255.255.255.255, a to z, A to Z, numerals 0 to 9, and special characters.

Password: User password. Supports up to 24 characters including a to z, A to Z, numerals 0 to 9, and special characters.

Mail Address (1 to 3): User’s e-mail address. Supports up to 24 characters including a to z, A to Z, numerals 0 to 9, and special characters.

The SMTP server IP address, port number, user name, and password are optional settings. The DVR can send e-mail without using an SMTP server or MTA (message transfer agent). In certain cases, e-mail should be forwarded to a SMTP server.

To set up the mail feature:

1. From the Network menu, click Mail.

2. Click the Notification box, and then select ON. The remaining boxes become available.

3. Click the remaining boxes to enter their settings.

4. Click SMTP Test to verify the SMTP server connection. A pass or fail message appears and a test e-mail message is sent to each e-mail address. The “Test email sent successfully” message indicates a successful SMTP server configuration. Verify that each addressee received the test e-mail message.

5. Click OK, and then click Close.

EMERGENCY NOTIFICATION SETUP

The emergency notification feature notifies the designated computer when an event occurs. The Emergency Agent application must be running on the computer when the event occurs. This event must be configured on the Notification menu. For information about configuring the notification option, refer to Notification Setup on page 43.

The emergency notification and e-mail notification features operate independently. The Emergency Agent application is installed on the remote client computer and is used to display and administer emergency reports. For information about setting up the e-mail feature, refer to Mail Setup on page 43.

The unit allows you to configure the following emergency notification settings:

Notification: Turns on and off the notification feature.

IP Address/Port: The remote computer’s IP address and port. Supported characters include 0.0.0.0 to 255.255.255.255.

SMTP Port No.: The default port is 9003. Supported values include 025 to 65535.

To set up emergency notification:

1. From the Network menu, click Emergency.

2. Click the Notification box, and then select ON. The remaining boxes become available.

3. Click the remaining boxes to enter their settings.

4. Click Close.

5. Click OK.