Windows Media Player 12 does not play some AVI files that were created by Pelco products.

NOTICE

POTENTIAL FOR DATA LOSS.
The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure, please contact Product Support Services prior to attempting the procedure below.

NOTICE

COMPLEX PROCEDURE REQUIRED.
The resolution of this article has many complex steps that may result in unforeseen results if not performed correctly. If you are at all unfamiliar with the requirements, please contact Product Support Services for assistance.

Issue

Microsoft Knowledge Base Article 2653030

You use Windows Media Player 12 on a computer that is running Windows 7 to play some AVI files that were created by a third-party application or by third-party hardware. The AVI files include an AVI super index chunk. In this scenario, Windows Media Player 12 does not play the files correctly.

Product Line

Pelco Video Management

Environment

  • Pelco AVI Formats
  • Windows Media Player 12
  • DX8100
  • DX4500/4600/4700/4800
  • DX Series Client

Cause

  • This issue occurs because Microsoft Media Foundation does not parse an index chunk in the AVI files correctly.

Resolution

A Microsoft supported hot fix is available from Microsoft.

Download Hot fix

Pelco does not guarantee the hot fix will work. Use VLC Player