Black Video when adding IP camera to a DX4700/DX4800.

Issue

Black video displays when viewing live or recorded video at a DX4700/DX4800 from an IP camera

Product Line

Pelco Video Management

Environment

  • DX4700/DX4800 (HD)
  • Pelco IP cameras
    • Note: Oncam Grandeye 360 camera is not supported.
    • version 2.0.1.00.0869, Onvif is only support for Pro series.
  • Axis Vapix 3 (version 5.x or later)
  • DX4700/DX4800 (nonHD)
    • All Pro series cameras are not supported. (IMP, IMP+, IBP, IBP+, IXP, IJP+, IWP+, P1220)

Cause

The DX4700/DX4800 can only interpret the "Baseline" profile of H.264.

Resolution

Live video at DX4700

  1. Log on to the IP Camera web interface
  2. Set IP camera H.264 profile to Baseline.
        *Below is an example of a Sarix IEE10DN (In the web interface go to:Settings>A/V Streams>Video Configuration):

 BaseLine

*Note: Some IP Cameras will not have the "Profile" option.   DX Series Client or DS ControlPoint client can be used on a PC which connects to the DX4700/DX4800 to display IP cameras using the MAIN profile.

Related Articles:
How to add an IP camera to the DX4700/DX4800 HVR?
Test IP Camera Message appears "IP Camera test failed" (Not enough bandwidth) on DX4700/DX4800.