Error 1720 There is a problem with this Windows Installer package.. when installing Digital Sentry software.

Issue

Installing the Digital Sentry installer on a DS NVs or DSSRV results in the following error.

Error 1720.There is a problem with this Windows Installer package. A script required for this install to complete could not run. Contact your support personnel or package vendor. Customer action PasswordNeverExpires script error -2147022676,: Line5, Column 1,

Product Line

Pelco Video Management

Environment

  • Digital Sentry
  • DS NVs
  • DSSRV

Cause

The Digital Sentry recorder has been joined to a domain with a password policy requiring 9 character or higher passwords.  The Digital Sentry default service user account has an 8 character password.

Resolution

When installing DS software, the user account "DSNVSUser" gets created with a 8 character password.  The DSNVSUser account is used for the MS SQL and DigitalSENTRY services. 

  1. Cancel the current installation after clicking OK on the 1720 error.
     

There are a couple of methods to resolve this issue:

Remove from the domain temporarily (recommended):

  1. Remove the Digital Sentry recorder from the domain (System Properties > Computer Name > Change > click on Workgroup > OK.)
     
  2. Install the Digital Sentry software.

NOTE: If you cannot install the Digital Sentry Software and continue to get the Error "1720" you can also disable the Local Security Policy password complexity requirement within windows. Steps are shown below.

  • Go to Control Panel
  • Click on System and Security
  • Administrative Tools
  • Local Security Policy
  • Go to Account Policies
  • Go to Password Policy
  • Click on " Minimum password length"  (If password length field is greyed out continue on to next step)
  • Change the "Password must be at least" field to the desired character number
  • And then go to "Password Must meet complexity requirements" and disable.

 

  1. Change the 'DSNVSUser' user account password to the required character length (Computer Management > Local Users and Groups > Users > right-click on the DSNVSUser account and select Set Password.
     
  2. Update the following services with the new password (Services > right-click the service and select Properties > select the Log On tab.)
    • SQL Server (DS_MSSQLSERVER)
    • IntegralSqlAgentService
    • DigitalSENTRY VideoServer Service
    • DigitalSENTRY Storage Service
    • DigitalSENTRY WatchDog Service
    • DigitalSENTRY PelcoAPI Service (if installed).
       
  3. Join the Digital Sentry system back to the domain.

 

Install without removing from domain:

  1. Verify in Programs and Features that there are no DS/Digital Sentry or SQL entries listed, if there is uninstall.
     
  2. Navigate to Computer Management > Local Users and Groups > Users.  Right-click on the Users folder and select New User...
    • User name: DSNVSUser
    • Full name: (leave blank)
    • Description: (leave blank)
    • Password: (create a password with the required amount of characters, example if 9 or more characters are required you could use Pelco1234
    • Confirm Password:
    • Uncheck "user must change password at next login", then check "Password never expires" and click Create.
    • Close
       
  3. The DSNVSUser account will now be listed in the Users window, right-click and select Properties.
     
  4. In DSNVSUser properties window select the Member Of tab and click Add...
     
  5. In the Select Groups window type in administrators and click the Check Names button.  This should show the computername/Administrators group, click OK to add.
     
  6. Click OK to close the DSNVSUser Properties window.
     
  7. Microsoft SQL Server needs to be installed manually, follow knowledge base article (complete all of the steps in the article with exception of a couple of steps listed below): Manual Installation of Microsoft SQL Server 2008 R2 Express on the Digital Sentry (DS) system

    - Step 5 admin #3, do not try and start the service as it will fail at this time due to login failure.
    - Step 9 You do not need to run the DS Quick Setup wizard at this time since the service passwords have not been updated.
     
  8. Once the process in the article, Manual Installation of Microsoft SQL Server 2008 R2 Express on the Digital Sentry (DS) system, has been completed, update the passwords with the new 9+ character password for the following services:
    (right-click the service and select Properties > Log On, update the passwords and then click OK.  For some services you may need to specify the DSNVSUser username as well as the password, as they may be set to Local System)
    (It is recommended to also change the Startup Type: to Automatic)
    • SQL Server (DS_MSSQLSERVER)
    • IntegralSqlAgentService
    • DigitalSENTRY VideoServer Service
    • DigitalSENTRY Storage Service
    • DigitalSENTRY WatchDog Service (Optional, not a required DS service. Used to monitor other DS services)
    • DigitalSENTRY PelcoAPI Service (if installed)
       
  9. Run the DS Quick Setup utility (Start > All Programs > Pelco > DS Quick Setup.)  Click Next, if prompted by User Access Control, select Yes.
     
  10. Select New Setup and then Next.  Follow the prompts and complete the new setup in DS Quick Setup.
     
  11. Verify live and recorded video in DS ControlPoint.
     

Related Articles:
Manual Installation of Microsoft SQL Server 2008 R2 Express on the Digital Sentry (DS) system
What is the default password for the DSNVSUser account in Digital Sentry