Binding between ES and AS or two AS shows Unresolved

Issue

When binding values between ES and AS or two AS, it will show Unresolved.

Product Line

SmartStruxure Solution

Environment

SmartStruxure

Binding between ES and AS or two AS

Cause

Failure of communicatoin has occured for one of the following reasons:

Firewall exists between the ES and the AS

In 1.4 and 1.5 the server name contains the & symbol

SmartStruxure fails to recognize the binding path with the name of AS or ES containing character "&".

Resolution

For Firewall Issues:

Ensure the windows firewall on the Enterprise Server PC is set up correctly, see LL#16184 for help with the firewall settings.

Problems with firewall settings can arise if the Enterprise Server PC is removed during the commissioning process and the firewall settings swap between Private Networks and Public Network.
For example
 - All the Automation Servers may appear online, but the "Unresolved" bindings issue may be seen.
 - Automation Servers cannot be restored via the Enterprise Server

Also check the IP setting in the Communications tab for all Servers (AS & ES) are set correctly 

For 1.4 or 1.5 Servers with a name containing the "&" symbol:

Ask for Product Support for Hotfix R1.4.1.16201 (or later version) for version 1.4 and R1.5.0.1601 (or later version) for version 1.5. 

 

For other Causes:

Follow these troubleshooting steps in order until the issue has been resolved.

  1. Check that the ES IP address is the same as the PC IP address. All ports must be open between the ES and AS. If they do not match, follow Lessons Learned Article #11135 to change the ES IP.
  2. Right click on the ES and select Advanced > Repair Server Communication. This should update the Communication tables of the servers.
  3. Detach the automation servers from the enterprise server and delete them. Then add the automation servers back. Follow Lessons Learned Article #8369.
  4. Select each AS and click on the Communication Tab. If communication is valid, it should list the ES and every AS
  5. To determine if this is a local firewall issue, disable the firewall on the ES PC, then repeat step 2. Wait a few minutes, then re-check each AS communication Tab.
  6. You can re-enable the firewall then add excepts to allow communication.
  7. Set up inbound and outbound rules for the Windows Firewall on the Enterprise Server. Follow Lessons Learned Article #11354.
  8. Try to disable network monitor function of the anti-virus software on the computer. If Schneider laptop is used, try to uncheck the monitor functions by right click on the McAfee anti-virus software. If this can help, try to ask IT to set the exception for the monitoring according to Lessons Learned Article #11354 so that the monitor function can be back to work.

If using the previous 1.2.0.767 release, a hotfix that can be provided by contacting product support and referencing this article needs to be installed first. This fix is in the later releases (like 1.3).

Depending on the Building Operations version that is running, a custom domain may need to be set up. In that case follow these steps.

How to setup a custom domain:
(If using 1.2.0.767 and have applied the hotfix then setup a custom domain)

  1. Create new domain.
  2. Create user groups (You cannot copy from Local) and setup permissions.
  3. Create Work-spaces (You cannot copy from Local)
  4. Select all users in the Local domain and drag to users folder in the custom domain.
  5. Assign users to groups
  6. Assign work spaces to groups.

And in the future they log into the system with the user in the custom domain.

If the problem persists, remove all StruxureWare domains from the ES and all AS.  Remove the AS and read, then rebuild the domains.