Right Click Menu for I/NET Converted TGML Graphic doesn't Work on Remote SmartStruxure Workstation

Issue

When clicking on the Right Click Menu for I/NET Converted TGML Graphic on remote SmartStruxure Workstation, nothing happens even though I/NET has already been installed on this computer and I/O server has been registered as service.

Product Line

TAC I/NET, SmartStruxure Solution

Environment

SmartStruxure

I/NET

Remote Workstation

Cause

On a 32 bit OS and a 64 bit OS machine, the I/NET Converted TGML Graphic are different because I/NET default software installation path is different:

32 bit OS: C:\Program Files\INET Seven\

64 bit OS: C:\Program Files (x86) \INET Seven\

Since the Right Click Menu calls the I/NET program, if the graphic is converted on 64 bit OS machine on the Server, it will not work on the Client machine with 32 bit OS. And vice versa.

Resolution

If there are mixed versions of 32 bit OS and 64 bit OS between ES and Remote Workstation, the I/NET graphics need to be converted on 64 bit OS machine. And then follow the steps below:

1. Manually create C:\Program Files (x86)\INET Seven\ folder on 32 bit OS machine.

2. Uninstall I/NET and reinstall it under the folder created instead of default one.

Then the Right Click Menu should work now.