Modbus values are not reporting correct values in workstation.

Issue

When comparing values of modbus registers within Workstation and Modscan the values do not match.

Product Line

SmartStruxure Solution

Environment

Enterprise server

Automation Server

Cause

The third party modbus device does not support single register requests.

Modscan was set to poll 10 registers as a group poll and giving the correct responses.

The modbus request in the Enterprise server was polling individual register one at a time. This resulted in incorrect responses from the third party device

Resolution

Add a modbus register group to the Server then add the modbus points to this group.

This will cause the Server to poll multiple registers in 1 request and get the correct response from the third party Modbus device