Excessive amounts of locked video causes a delay in the Quick Search bar to populate.

Issue

The Quick Search barThe Quick SearchdisplThe Quick Search bar displays the message "Please wait, searching for video...."
  • The Quick Search bar displays the message "Please wait, searching for video...."
  • The Quick Search bar can take over a minute to populate recorded video results.

Product Line

Pelco Video Management

Environment

  • Pelco Endura NSM5200
  • Pelco Endura WS5200 software

Cause

For every instance of locked video, the NSM5200 pool manager will query all the files on each NSD.

For example if there were 7,000 files of locked video and there were 3 NSM5200's in the pool each with 25,000 files, each piece of locked video would be compared to all the files in the NSM5200 pool.

7,000 x 25,000 x 3 = 525,000,000

Using these figures resulted in the Quick Search bar taking roughly 72 seconds to populate video. The results can be seen in the below Wireshark capture. The video request was sent out in packet number 23. The response to it (when the Quick Search bar populated) can be seen in packet number 934 which is 72 seconds later.

Resolution

Ensure the incident(s) have been exported from the system and unlock the video from that specific camera(s). Attempt to perform another search.