Unable to update the DX4700HD/DX4800HD through the DX Series Client.

Issue

The DX4700HD/DX4800HD is unable to be update from the DX Series Client.

Product Line

Pelco Video Management

Environment

  • DX4700HD
  • DX4800HD

Cause

Updating the DX4700HD/DX4800HD from the DX Series Client requires software version 2.01.00.0869 and above.

Resolution

Update the DX4700HD/DX4800HD to at least version 2.01.00.0869.

Related Articles:
How to update the DX4700 or DX4800 HVR software?
Where can I download the latest firmware version for DX4700/DX4800 Series DVR?