Patching Endura Devices for the Shellshock Vulnerability

NOTICE

POTENTIAL FOR DATA LOSS.
The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure, please contact Product Support Services prior to attempting the procedure below.

NOTICE

COMPLEX PROCEDURE REQUIRED.
The resolution of this article has many complex steps that may result in unforeseen results if not performed correctly. If you are at all unfamiliar with the requirements, please contact Product Support Services for assistance.

Issue

Some versions of the Linux operating system have a version of Bash (a Unix Shell) that can be exploited to issue unauthorized commands.

Product Line

Pelco Video Management

Environment

Endura Equipment:

SM5200

SM5000

NSM5200

VCD5202

NET5402R-HD

UDI5000-CAM

UDI5000-MTRX

Cause

This is a bug in the Linux Bash software.

Resolution

A zip file containing the Shellshock patches for Endura software, along with installation instructions, can be found here: Endura Shellshock (Must be Endura Certified to access the file)

 

NOTE:  Only attempt to install these patches if you have experience transferring files via SCP and running scripts from Endura Utilities.