Diagnose DS ControlPoint connection issues when connecting to DigitalSENTRY VMS.

Issue

DS ControlPoint attempts to connect to a DigitalSENTRY VMS, but fails for any number of reason.

Product Line

Pelco Video Management

Environment

  • DSSRV
  • DS NVs
  • DS ControlPoint client

Cause

DS ControlPoint fails to connect to DigitalSENTRY video system.

Resolution

Note: Clients operating on earlier versions of DS software will not function properly when connecting to a server running DS 7.13.84, update DS ControlPoint to v7.13 or later.

Verify everything:

  • error message during connection:
  • server software version:
  • client software version:
  • server hostname:
  • client hostname:
  • server IP address:
  • client IP address:
  • network topology: LAN/WAN/remote site via NAT/VPN
  • network cabling: UTP/Fiber/Wireless/Ethernet over Coax
    • After cables (copper or fiber optic) have been installed, have them certified

Troubleshooting steps:
Network verification:

  • ping server from client
  • ping server hostname from client
  • ping client gateway address from client PC
  • ping server gateway address from server
  • ping client gateway address from server
  • ping server gateway address from client
  • Click here to go to a Microsoft Technet article on how to ping.

Client configuration verification:

  • correct hostname or IP address
  • correct system type
  • correct username and password

 

Advanced troubleshooting steps to be performed in conjunction with the local IT department:

  • Antivirus software
    • Temporarily disable antivirus software on the client PC and server (if used)
    • If the connection is successful, start the antivirus software back up and configure it to allow DS ControlPoint to run
  • Local firewalls
    • Same as Antivirus step above
  • Port forwarding rules within NAT router
    • Verify the SQL Server, SQL Server Browser, and DS Video Server service are configured correctly
    • Visit portforward.com for more information
  • Port filtering within routers in the network
    • Same as NAT router step above
  • Network firewalls between internal/external networks
    • Same steps as Local Firewall and NAT router steps above
  • Network packet analysis (Wireshark or other packet capture utility)

 

Relate knowledgebase articles:
DS ControlPoint errors when connecting to a Digital Sentry system with "A network-related or instance-specific error occurred while establishing a connection to SQL Server".

What network ports are required for a remote connection to a Digital Sentry System?
Which network interface is used on the DSSRV (Digital Sentry)
Antivirus software on DigitalSentry hardware

Visit www.pelco.com/kb and enter the terms controlpoint, connect, and fail in the search bar.  If an error message is displayed when DS ControlPoint fails to connect, enter the message in the search bar within the knowledgebase page to see if there is a specific fix for that instance.