VideoXpert: Troubleshooting live stream issues

Issue

  • Offline devices will have a red "x" through the camera icon in OpsCenter and the Admin Portal.
  • OpsCenter may display the error "Cannot connect to video source".
  • OpsCenter may display black video.



Product Line

Pelco Video Management

Environment

VideoXpert Core version 1.5.6969.29
VideoXpert Media Gateway version 
1.4.6895.6
VideoXpert OpsCenter version 
1.5.4647.5

Cause

  • The workstation being used does not meet specifications.
  • The network is not configured correctly.
  • The edge device has a problem with either hardware or software.
  • The Media Gateway has a problem with either hardware or software.
  • The OpsCenter workstation may have a second network port that is enabled and plugged in. Disconnect this to troubleshoot.
  • Confirm the camera is configure for H264.

Resolution

  1. Attempt to ping the IP address of the camera listed in either the OpsCenter status window or what is listed in the Admin Portal window. If you do not get a reply, validate the physical Ethernet cabling is good. The confirm camera is plugged into the switch and powered on. Reboot the camera.
  2. Launch a web browser to the IP address of the camera and validate you can view live video from there.
  3. Install VLC and use LL#12001 to validate you can view both the primary unicast and primary multicast streams from the edge device. Do not proceed until you can view both.
  4. Validate you can view the unicast / multicast stream of the edge device through the Media Gateway by using the following string in VLC.

    rtsp://[IP address of the media gateway]:554/live/?streaming_uri=rtsp%3A%2F%2F[IP address of the edge device]%3A554%2Fstream1m

    rtsp://[IP address of the media gateway]:554/live/?streaming_uri=rtsp%3A%2F%2F[IP address of the edge device]%3A554%2Fstream2m

    Example: rtsp://192.168.1.100:554/live/?streaming_uri=rtsp%3A%2F%2F192.168.7.35%3A554%2Fstream1m

    **For NET5516 Encoders
    rtsp://[IP address of the media gateway]:554/live/?streaming_uri=rtsp%3A%2F%2F[IP address of the encoder]%3A554%2F[encoder_channel_number]%2Fstream1m
    rtsp://[IP address of the media gateway]:554/live/?streaming_uri=rtsp%3A%2F%2F[IP address of the encoder]%3A554%2F[encoder_channel_number]%2Fstream2m

    Example: rtsp://192.168.1.100:554/live/?streaming_uri=rtsp%3A%2F%2F192.168.5.102%3A554%2Fchannel1%2Fstream1m
     
  5. If Step 4 is not successful pull the logs from the Media Gateway from the below location and contact Pelco Technical Support.

    C:\ProgramData\Pelco\Gateway\data\log\*
    Note: The ProgramData folder is a hidden Windows folder, to reveal it click Start > Control Panel > Folder Options > View > Select Show hidden files, folders, and drives > click Apply then OK.
     
  6. If Step 4 is successful pull the logs from the OpsCenter from the below location and contact Pelco Technical Support.

    C:\ProgramData\Pelco\OpsCenter\*
    Note: The ProgramData folder is a hidden Windows folder, to reveal it click Start > Control Panel > Folder Options > View > Select Show hidden files, folders, and drives > click Apply then OK.