'TotalHistoricalRecords read so far' counter does not match the number of records read.

Issue

'TotalHistoricalRecords read so far' counter in the reporting agent log does not match the number of records read. Below is an example taken from a Reporting agent log:

INFO 2014-12-09 10:41:18 - TotalHistoricalRecords read so far = 59

INFO 2014-12-09 10:41:18 - The log has IncludeInReports = true

INFO 2014-12-09 10:41:18 - Trend LoggArray.FirstRecordInSource= 1

INFO 2014-12-09 10:41:18 - Trend LoggArray.LastRecordInSource= 9797

INFO 2014-12-09 10:41:18 - Last record stored in reports database = 9780

INFO 2014-12-09 10:41:18 - Getting records from server: start sequence = 9781, Number of recordsrequested = 17

INFO 2014-12-09 10:41:18 - TotalHistoricalRecords read so far = 75

In this case 17 records are requested: 9797-9780 = 17. Counter for 'TotalHistoricalRecords read so far' = 59 before getting logs. After getting logs, 'TotalHistoricalRecords read so far' = 75. 75-69 = 16. 

Product Line

SmartStruxure Solution

Environment

SmartStruxure WebReports

Enterprise Server 

Cause

This is caused by 'null' values in the extended trend log being read. Any value that equals 'null' in the extended trend log will not be added to the WebReports SQL database.

Resolution

None. The product is working correctly.