Pelco VMS Third Party API Integrations/Questions

Issue

End Users, Integrators or Developers need API support with a Pelco VMS.

Product Line

Pelco Cameras, Pelco Video Management

Environment

  • 3rd Party Integration
  • Endura
  • Digital Sentry
  • DX Series

Cause

We are seeing a growing number of Pelco products sold to customers that install them at their locations and have them working with various 3rd party applications / systems. This can make troubleshooting and helping our customers very challenging. To continue to provide exceptional customer service, the steps listed in the resolution are recommended.

Resolution

  1. Identify the callers role.
    • End User - Contact your local Integrator for any feature request / functionality issues.
    • Integrator - See Sections 2 - 4
    • Developer - See Section 5
  2. Verify the Pelco product(s) is/are working as designed.
    • Verify the feature or functionality trying to be accessed is supported on the Pelco product in question.
    • Verify Pelco products are at the latest firmware revisions.
    • Verify the Pelco product is operating correctly by itself.
      • For example, if a end user has an Endura system and cannot see video in the 3rd party application, put a WS5070 workstation in the same VLAN as the 3rd party application and validate you can view live and recorded video. Also test using the WS5200 from a different network location as the 3rd party application. If this is successful we can also make a reasonable assumption the the network is setup and operating properly.
  3. Verify the 3rd party application or system manufacturer is listed on Partner First (http://partnerfirst.pelco.com/partners).
    • Verify the integration/functionality the customer is requesting is listed.
    • If the integration / functionality the customer is requesting is not listed proceed to Section 4.
  4. Contacting the correct support personnel.
    • For Lenel, RS2 and Software House integrations.  Pelco's Partnering and Integration team developed the integration for these three companies. The integration piece that Pelco owns is the driver. The driver allows the 3rd party system to communicate with Pelco systems and edge devices.
    • Nearly all integrations with Pelco products (excluding 3rd party cameras with Pelco systems, Axis, Sony, Bosch, etc. with Endura, DS or DX) are developed by 3rd party manufacturers (Milestone, Genetec, Gallagher/Cardax, Hikvision, Exacq, eConnect, etc.). The integration code resides within their products or software and is maintained by each 3rd party company. Contact the appropriate 3rd party manufacturer after Sections 2 and 3 have been validated.
    • If they have not already, the 3rd party developers should register at http://pdn.pelco.com. This contains documentation resources relevant to integrations. It will also provide the appropriate contact options.
  5. Escalating issues.
    • If both companies products are working as expected but the functionality or features are not working correctly together, the 3rd party integration development team is the best group to continue to troubleshoot the issue. The 3rd party integration development team can verify if the features and functionality being troubleshoot actually exist via the integration. Also, they can access logs they potentially built into the 3rd party code and analyze any errors and other information in the logs and any other steps necessary to determine if the integration is the issue or not.
    • If necessary, the 3rd party developers already have established communication channels (in most situations) with Pelco's Partnering & Integration team that they can utilize for support.
    • Pelco Product Support will escalate the issue to the integration escalation manager.