Issue
Upgrading a File Master I/NET Seven Software from revision 1.10 through Revision 1.xx.
Environment
I/NET site
Cause
Possible problems with upgrading from I/NET 1.10 to 1.16
Resolution
There are some issues that users are running into when they upgrade their software over the Internet from earlier versions of I/NET Seven revision 1.10 through revision 1.16. Most commonly is that Equalization does not work and error messages are generated during the promotion of the Clients to the File Master. The following steps should be taken to avoid these problems:
- If Upgrading from I/NET 1.10 to 1.16, all the upgrades need to be done i.e. 1.10 to 1.12 to 1.14 to 1.15 and finally 1.16.
- On the File Master go to the DB Create Utility and force an upgrade on the database. A message comes up saying that you are set up as the File Master, do you want to drop Equalization. Select Yes, this will allow the user to drop all the clients that are connected to it.
- Start I/NET again and let the File Master re-promote itself. Once finished, open I/O Server, modify the active profile and uncheck the file master box.
- Once it becomes a Stand Alone Host again, close down I/O Server and shut down I/NET.
- Restart I/NET and follow step 3, this time check the box to promote Equalization again. This time you’ll get a box to enter a Password only, create a new Password.
- Upgrade the Clients Software and repeat step 3, removing the File Mater name from the box. Follow steps 4 and 5 and the user can put either the PC name or IP address of the File Master here.
- Once it receives the Snapshot from the File Master, verify that Equalization is taking place by comparing the databases, or make a change and verify that is was replicated.
- Now bring up all the remaining Clients by following steps 6 and 7.