What to do when the DSSRV system drive becomes full.

NOTICE

POTENTIAL FOR DATA LOSS.
The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure, please contact Product Support Services prior to attempting the procedure below.

Issue

The system drive, or drive C: in DigitalSENTRY becomes full and causes application instability.

Product Line

Pelco Video Management

Environment

DigitalSENTRY - all versions

Cause

DigitalSENTRY, Windows operating system, and other applications causes excess physical local drive usage which degrades the operating system performance for all applications.

Resolution

When the system drive becomes full, the Microsoft operation system doesn't have enough cache file space to function properly and system performance can become degraded. There are several ways to remove unnecessary files to increase hard drive free space and return the operating system to a stable environment.

  1. Remove unneeded exported video or other user files, often in the Documents and Downloads folders in the C: drive.
  2. Check the DigitalSentry database file size C:\Program FilesX86\Pelco\Database\DigitalSENTRY
  3. Check SQL log files: C:\Program Files (x86)\Microsoft SQL Server\MSSQL10_50.DS_MSSQLSERVER\SERVER\MSSQL\Log
    • Review any large ERRORLOG files then delete once the problem is identify.
  4. Check the following directory C:\Windows\Logs\CBS and delete CbsPersist.cab files
  5. Also check the C:\Windows\Temp directory and delete all files, files that are currently in use will not delete, just Skip those files when prompted.
  6. Run the Disk Cleaup application to remove unneeded system files.
  7. Disable hibernate or sleep mode.
    • To make hibernation unavailable, follow these steps:
      • Click Start, and then type cmd in the Start Search box.
      • In the search results list, right-click Command Prompt, and then click Run as Administrator.
      • When you are prompted by User Account Control, click Continue.
      • At the command prompt, type powercfg.exe /hibernate off and then press Enter.
      • Type exit, and then press Enter to close the Command Prompt window.
         
  8. Check the following directory for large usage C:\Windows\SoftwareDistribution
    • This is generally a download location for Windows Updates, the below process can be used to free up the space in this directory.
      • Start > Run
      • type cmd (run as administrator) and press enter.
      • type net stop wuauserv and press enter.
      • type rename c:\Windows\SoftwareDistribution softwaredistribution.old
      • type net start wuauserv
      • type exit and press enter
    • Verify a new SoftwareDistribution folder has been created, restart the video recorder and verify proper operation.  If you have no issues, delete the softwaredistribution.old folder and verify the space is now available to the C: drive.

 9. Click here to download Winderstat, a tool you can run to see exactly which files are taking up space on your system. Install and then run it as an administrator select just the C: drive when running it.


Recommended minimum hard drive space for Windows 7 64 bit environment is 20 GB, Windows XP is 1.5 GB.

Windows 7 system requirements

System requirements for Windows XP