VideoXpert: Managing Roles and Permissions

Issue

Additional roles need to be created to restrict users.

Product Line

Pelco Video Management

Environment

VideoXpert 1.8

Cause

A VideoXpert system by default only has an administrator role. 

Resolution

Open a web browser to the VideoXpert Core and login with [Username: admin Password: your_specific_password].

To Create a Role:

  1. Click the Users tab and under User Management click Roles. Click New Role.


     
  2. Name the role then click Save.
  3. By default all permissions are denied. Grant access as needed. Settings are saved immediately.
    In the below example the operator role has been granted the ability to view live video from any camera.
    Note that many permissions allow the selection of specific devices. It is possible to assign priority levels to users (1 being the highest and 250 being the lowest). Users with a higher priority can take control of devices from users with a lower priority.


     
  4. To restrict permissions to specific devices perform the following.
    Click the permission needing to be modified. View Video Sources is the below example. Under Resource Access select Selected Cameras. Click Configure Resources




    A pop up window will appear. Highlight the appropriate resource on the right then click Assign Selected. Click Done.

To Rename a Role:

  1. Go to the Users page then click on the Roles tab.
  2. Click the role you wish to rename.
  3. Click the edit button on the lower left corner of the window and select Rename.


     
  4. Provide a new name for the role then click Save.

 

To Delete a Role:

  1. Go to the Users page then click on the Roles tab.
  2. Click the role you wish to delete.
  3. Click the edit button on the lower left corner of the window and select Delete. Click Delete to confirm.

Proceed to Creating Users and Assigning them to a Role. See LL#17824.