DS ControlPoint displays Unknown Error when trying to live view or playback video from Oncam Grandeye cameras.

Issue

When trying to live view or playback video from Oncam Grandeye cameras, DS ControlPoint displays "Unknown Error".

Product Line

Pelco Video Management

Environment

  • DSSRV
  • DSSRV2
  • DSNVs
  • DigitalSENTRY software ver 7.5 or higher
  • DS ControlPoint versions 7.5 through 7.9
  • Oncam Grandeye 360° IP camera

Cause

DS ControlPoint will reserve memory for managing the Oncam Grandeye video stream, but does not release all of the reserved memory when the live view is switched to other cameras (memory leak).  Therefore, over a period of time, DS ControlPoint will run out of memory resources and display "Unknown Error" when you try to view live or playback video.

When memory utilization approaches 2GB, this problem will occur.

Resolution

This issue has not been seen in DS ControlPoint version 7.10, so the recommended resolution is to update DS ControlPoint to version 7.10 or later.

For versions between 7.5 through 7.9, in order to reclaim memory for DS ControlPoint, the application must be closed and re-opened.  Simply disconnecting from the system and reconnecting is not enough to free up the previously reserved RAM.