Resolving I/O module device address changed and Blacklisted device detection errors.

NOTICE

POTENTIAL FOR DATA LOSS.
The steps detailed in the resolution of this article may result in a loss of critical data if not performed properly. Before beginning these steps, make sure all important data is backed up in the event of data loss. If you are unsure, please contact Product Support Services prior to attempting the procedure below.

NOTICE

COMPLEX PROCEDURE REQUIRED.
The resolution of this article has many complex steps that may result in unforeseen results if not performed correctly. If you are at all unfamiliar with the requirements, please contact Product Support Services for assistance.

Issue

Some IO modules status showing as 'Blacklisted device detected" or "Address shift detected" or a system alarm is received indicating the condition.

AS trace logs may show one of the following entries...

2015-08-18 17:41:02.675 [1256862784] nsp.pin.cio.IODevice Module at address 14 is reporting Internal Error Code 32

2015-08-18 17:41:02.757 [1256862784] nsp.pin.cio.IODevice Module at address 28 is reporting Internal Error Code 32

2015-08-18 17:41:02.825 [1256862784] nsp.pin.cio.IODevice Module at address 12 is reporting Internal Error Code 32

2015-08-18 17:41:02.869 [1256862784] nsp.pin.cio.IODevice Module at address 13 is reporting Internal Error Code 32

2015-08-18 17:41:02.951 [1256862784] nsp.pin.cio.IODevice Module at address 15 is reporting Internal Error Code 32

 

2015-06-18 10:05:13.912 [1255584832] nsp.pin.cio.CIOException Error: Bad_Address (0xb0000), module Automation_Server_Io_Bus(31), moduleCode 0, dispString "AS address is invalid", techString "nsp_servers/plugins/CentralIOPlugIn/CIO/source/IOManager.cpp line 460"

2015-06-18 10:05:20.789 [1255584832] nsp.pin.cio.IOBus IOBusServer::run: Caught CIO exception from slot 3

 

Product Line

SmartStruxure Solution

Environment

Automation Server

AS

Cause

One or more terminal base may have to be replaced.

Intermittent IO connection (typically in S-cable).

Resolution

Click HERE for steps to resolve the problem.