Capture a modbus trace log in SBO

Issue

There is a need to capture a log that shows the Modbus communication in the AS or ES in order to troubleshoot an issue

Product Line

SmartStruxure Solution

Environment

AS Automation Server

ES Enterprise Server

Cause

When troubleshooting modbus issues in an AS or ES it can be helpful to see the communication

Resolution

  1. Navigate to [AS/ES name]/System/Modules/Trace/Loggers/nsp/nsp.pin.
  2. Right-click "nsp.pin.modbus" and choose properties.
  3. Under Level, change from "Information" to "Trace", then click ok.
  4. Let it run a few minutes. If there are some user input needed to recreate the modbus issue, do it.
  5. Retrieve the log by right-clicking [AS/ES name]/System/Modules/Trace/TraceSettings and choose Trace settings->Get trace log. 
  6. Save the log file somewhere you'll find it later.
  7. Change log level back to "Information" (reverse step 3).