Trend log values not updating in report server

Issue

After a specific date, trend log values are no longer transferred to the report server. 

In the table tbEventLogs, the column NumberOfRecords continously shows over 50000

Product Line

SmartStruxure Solution

Environment

Web Reports

Cause

For a currently unknown reason, at some point a mismatch between index sequence numbers and time stamps has occured, and therefore the same log values are attempted transferred over and over again.

Resolution

The reporting agent needs to be set up to read more records to get over trouble

1: Open the file "SE.WebReports.StruxureWareReportingAgent.exe.config" located in the reporting agent installation directory. Use notepad or similar.

2: Edit the line containing "numLogTimeRecordToRead"  changing the value 5000 to 20000

3: Restart the agent

4: Wait until the column NumberOfRecords in the table tbEventLogs shows a number lower than 20000

5: Change the value back from 20000 to 5000 in the config file

6: Restart the agent